Sunday 17 October 2010

Cisco Router behind a SOHO router settings

Please, anyone. Let me know if you find this useful!
I've just completed my CCNA and I found this router configuation so useful that I wanted to set it in stone before I forgot it. It allows me to set up my Cisco Lab router (2620) to connect to the internet via my home router (Linksys 44000).
You should be able to modify it for other types of routers - by matching your ISP router's gateway and subnet. The Cisco router uses fa 0/1 as the LOCAL LAN interface.
The WAN interface fa 0/0 connects to one of your ISP router's LAN ports.




! Set up for NAT/DHCP Cisco Router siting
! behind a Linksys Router (WRN4000)
! Johnny October 2010


!This line for local management
ip name-server 4.2.2.2

! Set up DHCP for your LAN (ethernet 0/1)
service dhcp
ip dhcp pool myDHCPPool
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
dns-server 4.2.2.2
exit

ip dhcp excluded-address 10.0.0.1

! My WAN Link - Plug this into one of your 4 Ports on your LinkSYS
! My Linksys router details are:- 192.168.1.0/24 GW:192.168.1.1

interface fa 0/0
ip address dhcp
no cdp enable
no ip route-cache
ip nat outside
exit

! Connect this to your 2900 Switch Port
! This is your Local LAN Port
interface fa 0/1
ip address 10.0.0.1 255.255.255.0
no cdp enable
no ip route-cache
ip nat inside
exit

access-list 10 permit 10.0.0.0 0.0.0.255
! Here we go go.
ip nat inside source list 10 interface fa 0/0 overload

! Routing table - Default Route to Linksys Router Gateway (192.168.1.1)

ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1

No comments: